Leaving the Mantis issue open until updating TR-532 without restriction on backward compatibility.
Content of the Mantis Bug Tracker:
The term "Type" is generally used for indicating data types.
Names of attributes should not contain this term.
Wherever required, the term "Kind" should be applied instead.
Three occurrences of the problem have been identified.
HybridMwStructureCapability::supportedTdmStructureTypesList attribute should be renamed to HybridMwStructureCapability::supportedTdmStructureKindList.
HybridMwStructureConfiguration::structureType attribute should be renamed to HybridMwStructureConfiguration::structureKind.
TypeDefinitions::SegmentStatusType::segmentStatusTypeId attribute should be renamed to TypeDefinitions::SegmentStatusType::segmentStatusId.